Archive

Posts Tagged ‘ganymede’

Si no arranca eclipse

June 11, 2009 3 comments

Espero que les sirva este post para los que usan eclipse.
Si no arranca su eclipse por que hicieron alguna actualizacion u otro, podrian probar siguiendo estos pasos de NUESTRO AMIGO (slack).

lunes 13 de abril de 2009
Error al arrancar Eclipse
Hola, en algunos casos el sistema operativo se marea con la jvm que ocupa, esto generalmente ocurre cuando hacemos alguna actualización de algún paquete con el gestor o comando alternatives.
Y cuando queremos arrancar eclipse desde el lanzador del escritorio, simplemente no lo abre. y comenzamos con cuestionamientos… jajajaj…, en este caso lo logico es que queramos abrirlo por consola con el comando

slack@zion:programas/eclipse$ ./eclipse
LOG: [0xb7eb66b0] exception thrown while VM is initializing:
LOG: [0xb7eb66b0] NULL: java.lang.Object
LOG: [0xb7eb66b0] Aborting…
Aborted

desplegando el mensaje de error que se ve, lo bueno de esto es que existe una rapida solución.

En la misma consola ejecutamos el siguiente comando para comprobar las jvm disponibles para usar en el sistema,

slack@zion:~/programas/eclipse$ sudo update-alternatives –config java
[sudo] password for slack:

Hay 2 alternativas que proveen `java’.

Selección Alternativa
———————————————–
1 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
*+ 2 /usr/lib/jvm/java-6-cacao/jre/bin/java

Pulse para mantener el valor por omisión [*] o pulse un número de selección: 1
Se utiliza `/usr/lib/jvm/java-1.5.0-sun/jre/bin/java’ para proporcionar `java’.

Luego comprobamos que la opcion seleccinada sea la que tome el sistema como version de uso para java.

slack@zion:~/programas/eclipse$ java -version
java version “1.5.0_16”
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b02)
Java HotSpot(TM) Server VM (build 1.5.0_16-b02, mixed mode)

Con esto debieramos tener solucionado el tema de incompatibilidad de jvm con eclipse, al menos.

Saludos y Suerte !!

Inspeccionar funciones en PHPEclipse

Luego de descargar un proyecto PHP desde un repositorio SVN en Eclipse. (Aqui un Howto para descargar Dokeos desde su servidor SVN). Sucede el clásico error de querer inspeccionar includes, funciones, clases en PHP sin éxito. El motivo es que el archivo .project de nuestro proyecto no está asociado con un proyecto PHP según Eclipse.

En otras palabras, se debe modificar el archivo .project agregando el siguiente código:

<buildSpec>
<buildCommand>
<name>net.sourceforge.phpeclipse.parserbuilder</name>
<arguments>
</arguments>
</buildCommand>
</buildSpec>
<natures>
<nature>net.sourceforge.phpeclipse.phpnature</nature>
</natures>

Esto indica a Eclipse que nuestro proyecto es un PHP Project. Voila!

Visto aquí

Instalar Eclipse Ganymede + PHPEclipse + Subclipse + Dokeos dev-1.86 en Ubuntu 8.04

July 24, 2008 12 comments

Luego de tener problemas con la Eclipse 3.2 y de intentar dejar PHPEclipse por Zend Studio, tenía tantas ganas de que PHPEclipse vuelva a funcionar como aquel verano del 2008 donde todo simplemente funcionaba bien. Ahora, con la última versión de Eclipse 3.4 Ganymede hice el proceso de instalación que verán en las siguientes lineas y todo funcionó.

Antes que nada se debe de desinstalar algún rastro es decir del Eclipse 3.2, para ello pueden visitar este post.
Ahora comenzamos con:

1. Instalar Eclipse 3.4 Ganymede
http://download.eclipse.org/eclipse/downloads/

Descargué la siguiente versión: Linux (x86/GTK 2) y lo descargué desde el servidor Columbia muy rápido aqui en Perú. Descomprimir el archivo tar y ejecutar el archivo ./eclipse

Si no tienen el Java Runtime Enviroment es necesario instalarlo:

sudo apt-get install sun-java5-jre

Esto instalará el Eclipse para un usuario solo (instalarlo para todos los usuarios de esta máquina necesita más trabajo y grabar los archivos dentro de un directorio compartido). Un buen lugar para instalarlo para un usuario único es dentro de /home/usuario/src por ejemplo, si es que tienen un directorio para fuentes de programas.

Seleccionar el workspace: por default seleccionar la dirección pública del servidor Apache, en mi caso: /var/www/
(Es necesario que esta carpeta tenga permisos de escritura)

2. Instalar el Plugin – SubEclipse

Seguir los detallados pasos aqui: http://subclipse.tigris.org/install.html
Para esta instalación seleccioné http://subclipse.tigris.org/update_1.4.x

3. Instalar PHPEclipse
El proceso es similar al Plugin SVN pero se debe de agregar el sitio http://update.phpeclipse.net/update/stable/1.2.x/

4. Crear un nuevo proyecto en Eclipse

a. File->New -> Other -> SVN -> Projects from SVN
b. Agregar la dirección de SVN de Dokeos: https://dokeos.svn.sourceforge.net/svnroot/dokeos/trunk
De la lista seleccionar “Dokeos”.
c. Seleccionar “Checkout as a project in the workspace”. y colocar un nombre por ejemplo “dokeossvn”
d. Done!

Comenzará la descarga de Dokeos desde el repositorio SVN.

Si a este punto Eclipse enseña un error acerca del cliente SVN que no se pudo cargar, verifica que todos los elementos del repositorio de Subclipse (es muy probable que necesite JavaHL) sean instalados y vuelve a probar.

Es necesario realizar este pequeño truco para cambiar el proyecto de SVN a PHP y poder hacer inspecciones dentro de funciones, includes, etc. No olviden cambiar la perspectiva a PHP, por default es JAVA.

5. Ver resultados

Luego acceder a localhost/dokeossvn suponiendo que tienen esta dir /var/www/dokeossvn et voila!

Para más información sobre Dokeos y su repositorio SVN : http://www.dokeos.com/wiki/index.php/SVN

%d bloggers like this: