Home > Development, Dokkeos, English > Fix your database between 1.8.5 RC1 and 1.8.5 stable

Fix your database between 1.8.5 RC1 and 1.8.5 stable

A few typos went into the upgrade code from 1.8.4 to 1.8.5 RC1, so if you went through this particular setup, you’re going to have to fix a few things manually:

  1. The queries about the required fields in the user profile were missing a quote, so you want to execute, inside your main database, the 3 first queries below
  2. It won’t help you much as the error has already been made, but the survey tool that now appears in the interaction section is visible by default, which is acceptable for a new course, given the teacher has to go through it anyway, but is not (acceptable) for an existing course. The value to change is the “visibility” field in the “tool” table of each course, for the last record of the table, generally, and you want to change it to a visibility of “0”.

The queries:

INSERT INTO settings_current (variable, subkey, type, category, selected_value, title, comment, scope, subkeytext) VALUES (‘extendedprofile_registrationrequired’, ‘mydiplomas’, ‘checkbox’, ‘User’, ‘false’, ‘ExtendedProfileRegistrationRequiredTitle’, ‘ExtendedProfileRegistrationRequiredComment’, NULL, ‘MyDiplomas’);
INSERT INTO settings_current (variable, subkey, type, category, selected_value, title, comment, scope, subkeytext) VALUES (‘extendedprofile_registrationrequired’, ‘myteach’, ‘checkbox’, ‘User’, ‘false’, ‘ExtendedProfileRegistrationRequiredTitle’, ‘ExtendedProfileRegistrationRequiredComment’, NULL, ‘MyTeach’);
INSERT INTO settings_current (variable, subkey, type, category, selected_value, title, comment, scope, subkeytext) VALUES (‘extendedprofile_registrationrequired’, ‘mypersonalopenarea’, ‘checkbox’, ‘User’, ‘false’, ‘ExtendedProfileRegistrationRequiredTitle’, ‘ExtendedProfileRegistrationRequiredComment’, NULL, ‘MyPersonalOpenArea’);

That’s it, basically. I just wanted to point it out because there are about 100 campuses already in existence using the RC1 version of Dokeos, following the information given by the registration process, and I thought these people might want to fix their database…

Note, however, that this only affects people using a beta or RC1 system that they used to *upgrade* a previous installation of Dokeos <= 1.8.4. None of the other folks (installing a fresh RC1 or upgrading from 1.8.4 to 1.8.5 stable) will be affected.

Advertisements
Categories: Development, Dokkeos, English
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: