Home > English, OSS Solutions, Tech Crunch > HOWTO Install Tulip IDE on Debian Sarge

HOWTO Install Tulip IDE on Debian Sarge

This article was first written in May 2004 for the BeezNest technical
website (http://glasnost.beeznest.org/articles/129). The Tulip IDE project
has now been inactive for several years.

This manual is meant to help people who would like to install Tulip IDE on a Debian Sarge system.

Latest addition

As of Tulip version 0.7, the best way to have it running on your Debian system is probably to use the pre-compiled version of libraries available in the second tab on the Linux install page, because all other packages’ versions are really different. To keep it easy, take the following steps:

  • download the pre-compiled libraries for php-gtk here
  • tar zxvf php-gtk.tar.gz
  • mv php-gtk/ /usr/local (as root and only to make it available for all users)
  • download tulip here
  • unzip tulip-0.7.zip
  • cd tulip-0.7
  • /usr/local/php-gtk/php/bin/php tulip.php

You might not want to make the same Tulip directory available for many people as the config files are not well located at the moment (not user-orientated)

Previous document


As of 30 May 2004, some packages are on Tulip’s website (see above link) for GTKScintilla and PHP-GTK on Debian (as well as all the other packages you may need additionally – libglade0 for example – but which are already into Debian Sarge).

However, I have tested the packages and it seems like PHP-GTK has been compiled with libstdc++-libc6.1-1.so.2, or anyway, php_gtk.so looks for that file in /usr/lib. I simply placed a link (as root) like this, as my version of libstdc++-libc6 is 2-2:

ln -s /usr/lib/libstdc++-libc6.2-2.so.3 /usr/lib/libstdc++-libc6.1-1.so.2

Now it launches perfectly with just that. (well, still got some GtkWarnings in the terminal but this will be fixed soon I suppose…)

The following, until section “Tulip” should not apply anymore, but remains just in case…

Here goes…

A lot of problems occured on my way to get Tulip working, so I hope this will help you a bit.


First of all, you need to install gtkscintilla. Maybe there’s a way to avoid using a non-packaged gtkscintilla, but I didn’t find any. There’s a reference to it being packaged for X11 on FreeBSD, but on the SourceForge project page (link below) there’s only rpm packages.

Why gtkscintilla? Because Tulip relies on it to run. As you could see in the classes/editor.php file in the Tulip directory, the system guesses this little library is installed. The version of gtkscintilla I used is 0.8.2. There is already a 2.x version, but I think I’ve seen somewhere that Tulip just needs 0.8+ Anyway, here goes:

To download gtkscintilla, go get it on its Sourceforge page. You can just click here to download it (link available at the time this article was written).

Once downloaded, install it following the readme instructions tar zxvf GtkScintilla-0.8.2.tar.gz cd GtkScintilla-0.8.2 make su make install /sbin/ldconfig exit

Note that the installation indicates where the files are written. Maybe that could be useful for you (it wasn’t for me).


No Debian package for this one either. The only package that ever existed has been left out by its packager due to a lack of time. Too long ago to be even installable with the current Debian Woody.

Anyway, to install php-gtk, you could use their documentation but I’ll tell you anyway and this will be faster.

To download php-gtk, they recommend to get it from the CVS repository. I wonder why because even the cvs version is broken, but still, this is the version counting the lesser bugs, so do it:

cvs -d :pserver:cvsread@cvs.php.net:/repository login cvs -d :pserver:cvsread@cvs.php.net:/repository co -r PHP_GTK_1 php-gtk cd php-gtk ./buildconf aclocal ./buildconf

I make a little pause here. There is a mention of an error in the configure file at this stage. I had this error indeed but don’t get it anymore, so just in case, before proceeding, check in your ./configure file that the lines 3397 and 3398, if containing (first line) “PHP_GTK_ARG”, are commented. If there is no such “PHP_GTK_ARG” there or really near, just proceed to the installation.

Note here that we’ll be using –enable-scintilla. This is REALLY important as if you don’t put it, php-gtk will consider gtkscintilla is not there and later Tulip won’t run.

./configure –enable-scintilla make make install

Now there’s still one step. It is indicated at the end of the php-gtk’s installation process. You have to link from the php directory to the file contained in the install directory (where you installed php-gtk, so normally where you are still now). To do so:

su ln -s /fullpath_to_where_you_are/modules/php_gtk.so /usr/lib/php4/20020429/php_gtk.so exit

Tulip IDE

Now you still need to install tulip. This is a trivial part as it is php-gtk and you simply start it with php tulip.php Download Tulip here, install it and run it: unzip tulip-0.2.zip cd tulip php tulip.php

There you go. Now there could be other problems waiting but you got your first free and open source step into this php coding IDE.

I’d like to thank Paolo for this great start on Tulip and for the link on Tulip’s website.

  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: